It’s Official, Our Newest Mac is Too Old

iTunes 10 won’t install on OSX 10.4.11 on the 1st gen flat panel G4 iMac. /sigh #obsolescence

Published by

Hal

I am the non-admin personality of blivet tool & die I have been academically trained as a professional archaeologist (MA, RPA) and now live in Arvada, CO. Father, husband, scientist, geek of several trades, and high-functioning Autistic adult. Future planetary expatriate?